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Problem

In Registration Client, it is mandatory for an operator for performing onboarding before using the registration client. During onboarding, an operator need to provide his/her biometrics for authentication which is verified by the ID authentication internal service.

But after providing the biometrics we see that there is an error in the screen stating that there was a failure during onboarding.

Root Cause Analysis

The issue can occur due to the below reasons

  1. There is no mapping for operator’s biometrics in the IAM

  2. There is mapping but the field attribute name is not set properly

  3. The RID set is not valid and doesn’t have a valid UIN mapped

  4. The UIN is not available in identity cache of IDA

  5. The biometrics in the mapped UIN record and in IDA don’t match

Solution

The issue is resolved by making sure the below steps are be followed before we initiate onboarding,

  1. The operator should have registered in MOSIP and his/her UIN should be available in identity cache and authentication should be allowed for the UIN (authentication should not be locked & UIN should be active)

  2. The RID of the user should be mapped against the operator’s user ID in the IAM and the attribute name should be “rid” (it is case sensitive).

  3. The ID Authentication and Registration Processor services should be up and running.

If the operator is the first user in MOSIP ecosystem then we can give the operator, the role called “Default” (it is case sensitive), so that, on-boarding can be bypassed for the operator in registration client.

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